[OE-core] [PATCH] image: rename image-wic -> image_types_wic
Ed Bartosh
ed.bartosh at linux.intel.com
Wed Feb 1 15:27:49 UTC 2017
Make name of the wic image type class consistent with
existing naming scheme for image types.
Signed-off-by: Ed Bartosh <ed.bartosh at linux.intel.com>
---
meta/classes/image.bbclass | 5 +++--
meta/classes/{image-wic.bbclass => image_types_wic.bbclass} | 0
2 files changed, 3 insertions(+), 2 deletions(-)
rename meta/classes/{image-wic.bbclass => image_types_wic.bbclass} (100%)
diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
index 613cd92..b5a4fb4 100644
--- a/meta/classes/image.bbclass
+++ b/meta/classes/image.bbclass
@@ -151,6 +151,9 @@ def build_uboot(d):
IMAGE_TYPE_uboot = "${@build_uboot(d)}"
inherit ${IMAGE_TYPE_uboot}
+IMAGE_TYPE_wic = "image_types_wic"
+inherit ${IMAGE_TYPE_wic}
+
python () {
deps = " " + imagetypes_getdepends(d)
d.appendVarFlag('do_rootfs', 'depends', deps)
@@ -187,8 +190,6 @@ python () {
IMAGE_CLASSES += "image_types"
inherit ${IMAGE_CLASSES}
-inherit image-wic
-
IMAGE_POSTPROCESS_COMMAND ?= ""
# some default locales
diff --git a/meta/classes/image-wic.bbclass b/meta/classes/image_types_wic.bbclass
similarity index 100%
rename from meta/classes/image-wic.bbclass
rename to meta/classes/image_types_wic.bbclass
--
2.1.4
More information about the Openembedded-core
mailing list